Tuesday, 13 March 2012

Unexpected error occurred user profile service application

Unexpected error occurred when accessing user profile service application

This happened after restarting user profile services via central admin. Launched ULS viewer and found this error

UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception: System.IO.FileLoadException: The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)   

Launced command prompt and executed the iisreset on the server where user profile is provisioned.

Iisreset  /noforce

Boom issue resolved :)

If this doesn't work for you, check the ULS Logs for more info to troubleshoot this. Its a handy tool.

I would stop the user profile services from central admin
Check if the forefront services are stopped
If both services started, check forefront services if they are started
Check if you're able to launch Forefront synchronization service manager

If the user profile services are stuck in starting stage, follow the steps mentioned here


This may help in resolving the issue.


  1. I have very same problem when click on manage. HAve performed many iisresets but still receive unexpected error. Any advice welcome

  2. Is your user profile and central admin provisioned on the same server or different servers. Stop User Profile and then sync services. iisreset. Start the services and may have to run iisreset one more time. If its on different box, you will have to run iisreset on both boxes.

  3. I have the same problem as andy dale. Did you Resolve this problem? do you have any advice?

    The magic iisreset didnt work for me. Ill try to track with uLS viewer

  4. are the user profil and sync service running for you? Stop and start it. check the two forefront services in services.msc if they're started when you restart user profile from central admin. after that give an iisreset if it works great, if not check the uls logs i assume you're goanna do that anyways. whats the service account you're using for user profil? farm one or a different one? each and every sharepoint environment is unique and this worked for me but you may have to rely on uls for more info. its handy to look at the version of sp, rtm or sp1 and see if there are any fixes for the same. it will take 10-15 minutes when yuo restart the service I would launch uls viewer when starting the service to see if there is something else causing this. i hope this helps.

    1. Vinod, there is no relation between User profile Service Application page and Forefront windows Services. These Fim Services come into picture when you start synchronization. In order to see the application page, User Profile Service should be started in manage services on server.