Thursday, 3 May 2012

Database is in compatibility range and upgrade is recommended

Recently created a development box for our developers and as a part of this had to copy the production data into it. Followed the content database migration approach worked well but this error popped in later.

Database is in compatibility range and upgrade is recommended. The following databases have versions that are older than the current SharePoint software, but are within the backwards compatible range.


$contentdb = Get-SPContentDatabase | Where-Object {$_.Name -match  "WSS_Content_First"}

Upgrade-SPContentDatabase -Identity $contentdb

This worked for one of the content database but for the second one it failed.  Had a look at the log files and there was some class id missing. All solutions were deployed was bemused. Used my lethal weapon PSconfig but this one failed:

PSConfig.exe -cmd upgrade -inplace b2b -wait

Had no choice to unleash the force beast, ran this:

PSConfig.exe -cmd upgrade -inplace b2b -force

This one worked all well and now don’t see any more upgrade required message. Happy days.


  1. "WSS_Content_Frist"}

    Try First not Frist..
    copied and pasted this.. didn't work.. took me a minute

  2. recommended approach is to Run PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

  3. This comment has been removed by the author.

  4. Thanks for sharing--This fixed my issues in SharePoint 2013 with these database warnings.

  5. Thank you. PSConfig.exe -cmd upgrade -inplace b2b -wait worked for me in SharePoint 2016.

  6. how to solved one of Search LinksStore Database is in compatibility range.
    i executed PSConfig.exe -cmd upgrade -inplace b2b but same issue am facing