Wednesday, 13 March 2013

SharePoint 2010 October 2012 Cumulative Update a nightmare



 Got this error while running the Configuration Wizard on a Test environment which constitutes of a App and WFE server after installing the October 2012 Cumulative Update.

An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: The upgrade command is invalid or a failure has been encountered.
Failed to upgrade SharePoint Products.
Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Exception of type 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException' was thrown.
   at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
 Resource id to be retrieved is PostSetupConfigurationFailedEventLog for language English (United States)
Resource retrieved id PostSetupConfigurationFailedEventLog is Configuration of SharePoint Products failed.  Configuration must be performed in order for this product to operate properly.  To diagnose the problem, review the extended error information located at {0}, fix the problem, and run this configuration wizard again.
Leaving function StringResourceManager.GetResourceString
Configuration of SharePoint Products failed.  Configuration must be performed in order for this product to operate properly.  To diagnose the problem, review the extended error information located at fix the problem, and run this configuration wizard again.
Entering function StringResourceManager.GetResourceString
Upgrade Timer job is exiting due to exception: System.Data.SqlClient.SqlException: Cannot open database "Search_Service_Application_1_CrawlStoreDB  " requested by the login. The login failed.
Login failed for user


Steps performed to reach towards resolution:

Installed October 2012 Cumulative Update on WFE and APP Server
Ran Product Configuration Wizard and it failed
Tried PSConfig.exe -cmd upgrade -inplace b2b –wait  - This too failed at the last step
Tried psconfig -cmd upgrade -inplace b2b –force – this too failed at the last step
IISRESET to both SharePoint Servers
Restarted SharePoint Timer Service
Restarted SharePoint Search Service
Ran PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures – this one failed at the last step

Failed why: There was an issue with the culture it was finding the culture as United States rather than United Kingdom

Note: The cumulative updates are bundled into one package from October 2012 onwards i.e. contains the foundation, server , language packs in the same package

Ran psconfig -cmd installcheck –noinstallcheck  - this worked fine but failed again at the last step

Failed why: the error was due to the crawl and admin databases of search

Cleared the SharePoint Cache on btoh WFE and APP Servers

Ran Get-SPProduct -local
PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

This solved the issue phew. This was one nasty thing to install the October 2012 CU.

I don't know what I would have done without the ULS Log my good friend.

2 comments:

  1. BlueHost is ultimately one of the best hosting provider with plans for all of your hosting needs.

    ReplyDelete
  2. If you want your ex-girlfriend or ex-boyfriend to come crawling back to you on their knees (no matter why you broke up) you have to watch this video
    right away...

    (VIDEO) Why your ex will NEVER get back...

    ReplyDelete